0
Under review

unable to create foreign key relationship

alastair 3 months ago updated by jasonbohanon 2 months ago 9

I have defined a few tables and relationships, however, between some tables I am unable to create a relationship.

Say I have 2 tables D and U where U is defined as a child to D

Then I have 3 other tables C as a parent of S as a parent or T

and what I now need to do is define a relationship between D and T

I select the non-identifying relationship button, click on D and move the cursor over T, but all that happens is that T flashes, and I cannot choose it

I created another table A and made that a child of D

Does anyone know of reasons why I would not be able to link 2 tables which do not have a relationship currently, and where the new relationship would not cause any kind of relationship confict?

I've hit this a couple of times yesterday and I found just saving my model was enough to then permit the join to be created.  Sometimes I had to move the tables on the canvas as well.   It's a bit of a weird one.

Under review

Dear User,

  Sorry for the inconvenience.


We are unable to replicate the issue. Following is what we have created based on your explanation. There was bug a while back about flashing child table while creating FK, but it has been fixed long ago. 


I would suggest, please try to delete browser cache and close & open browser and then try again OR try moving child table on right side of parent before creating relationship.


Let us know if problem persists.

Thanks,
Team - SqlDBM

Same thing happened again this morning

I needed to define a new relationship between 2 entities and could not with the same flashing child entity.

I saved, unlocked, and reloaded the page, still the same issue

Then I switched to a simpler diagram containing the same entities, and could create the link.

Next time i encounter it, I will be more diligent in capturing the exact steps and steps to resolution, but this is still an issue.

I did also receive another response which said they had the same issue and that saving resolved it, however saving along does not always solve it for me

Again this morning - issue repeated

1) created new entity

2) created second new entity to be an intersect between (1) and a pre-existing entity, placed this entity below and slightly left on the diagram of (1)

3) tried to link 1 to 2 - 2 flashed and not selectable

4) did not save but moved 2 to the right of 1

5) tried to link 1 to 2 that worked 

6) completed the link to other pre-existing entity where on the diagram 2 was above and to left of pre-existing, link worked


Saved, and decided to just repeat above to see what happens and if save  between #2 and #3 solved the issue it did not. but again moving the entity to the right did solve the problem

It does appear that there is some intermittent issue with linking with the child to the left.

 

some more information - I just repeated this again, and tried different alignments

Parent with Child below and completely left - failed

Moved to

Parent with Child below and spanning parent left boundary - failed

Moved to

Parent with Child below and completely within parent horizontal boundary - failed

Moved to

Parent with Child below and spanning right boundary - failed

Moved to

Parent with Child below and completely to right - Success

then I took the time to move the child all around the parent and found that linking is not possible, when the child both:

1) mostly below the parent (does not have to be completely, but if mostly below level of bottom of parent

2) to the left of the parent right boundary, or partly spanning the right boundary of parent  

there is only one exception to this and that is if the child has a small amount of overlap with the parent right boundary then the child can be selected at the very right edge of the child, but not in the middle or left, and the more horizontal overlap with its parent while still below, the less selectable area of the child is available.

I am having the same issue where I am not able to create FK links.  Placing "child" table on top of "parent" table made it work

I am having the same issue too.  I just started using the app so I don't think I have an older version.  It just flashes and doesn't allow me to connect to the child table.  I am using a Mac with latest OS and Chrome.

Thank you very much for your feedback. Our team will be on it. We should be able to fix it by next release. 

Sorry for the inconvenience. 

Best,

Team SqlDBM

I discovered that this only happens after at least 3 tables have been added to the model.  Also, if I move the parent table to below the child in the diagram before drawing the line, the relationship connection will then work properly.